SA132: OpenSSL Vulnerabilities 22-Sep-2016 and 26-Sep-2016

Back to all Security AdvisoriesFollow
Security Advisories ID: 
SA132
Published Date: 
October 6, 2016
Advisory Status: 
Interim
Advisory Severity: 
High
CVSS v2 base score: 10.0 (AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVE Number: 
CVE-2016-2177 - 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVE-2016-2178 - 2.1 (LOW) (AV:L/AC:L/Au:N/C:P/I:N/A:N)
CVE-2016-2179 - 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVE-2016-2180 - 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVE-2016-2181 - 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVE-2016-2182 - 7.5 (HIGH) (AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVE-2016-6302 - 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVE-2016-6303 - 7.5 (HIGH) (AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVE-2016-6304 - 7.8 (HIGH) (AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVE-2016-6305 - 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVE-2016-6306 - 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVE-2016-6307 - 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVE-2016-6308 - 7.1 (HIGH) (AV:N/AC:M/Au:N/C:N/I:N/A:C)
CVE-2016-6309 - 10.0 (HIGH) (AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVE-2016-7052 - 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P)

Blue Coat products using affected versions of OpenSSL are susceptible to multiple vulnerabilities.  A remote attacker can exploit these vulnerabilities to recover private DSA keys or execute arbitrary code through integer overflow and buffer overwrites.  The attacker can also cause denial of service through application crashes, endless CPU loops, and dropped connection packets.

Affected Products: 

The following products are vulnerable:

Advanced Secure Gateway
ASG 6.6 prior to 6.6.5.2 is vulnerable to CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306.

Android Mobile Agent
Android Mobile Agent 1.3 prior to 1.3.8 is vulnerable to CVE-2016-2182.

BCAAA
BCAAA 6.1 is vulnerable to all CVEs except CVE-2016-2180, CVE-2016-6305, CVE-2016-6307, CVE-2016-6308, CVE-2016-6309, and CVE-2016-7052 when a Novell SSO realm is used.

CacheFlow
CacheFlow 3.4 is vulnerable to CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306.

Client Connector
Client Connector 1.6 is vulnerable to CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306.

Content Analysis System
CAS 1.3 is vulnerable to CVE-2016-2177, CVE-2016-2182, CVE-2016-6302, CVE-2016-6304, and CVE-2016-6306.

Director
Director 6.1 is vulnerable to CVE-2016-2182, CVE-2016-6302, CVE-2016-6303, CVE-2016-6304, and CVE-2016-6306.

Mail Threat Defense
MTD 1.1 is vulnerable to CVE-2016-2177, CVE-2016-2182, CVE-2016-6302, CVE-2016-6304, and CVE-2016-6306.

Malware Analysis Appliance
MAA 4.2 prior to 4.2.11 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2182, CVE-2016-6303, CVE-2016-6304, and CVE-2016-6306.

Management Center
MC 1.7 and 1.8 are vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2180, CVE-2016-2182, and CVE-2016-6306.

Norman Shark Industrial Control System Protection
ICSP 5.3 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2182, and CVE-2016-6306.

Norman Shark Network Protection
NNP 5.3 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2182, and CVE-2016-6306.

Norman Shark SCADA Protection
NSP 5.3 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2182, and CVE-2016-6306.

PacketShaper
PS 9.2 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-6303, CVE-2016-6304, and CVE-2016-6306.

PacketShaper S-Series
PS S-Series 11.2, 11.3, 11.4, 11.5, and 11.6 prior to 11.6.2.2 are vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2180, CVE-2016-2182, CVE-2016-6302, CVE-2016-6304, and CVE-2016-6306.  PS S-Series 11.7 is not vulnerable.

PolicyCenter
PC 9.2 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-6303, CVE-2016-6304, and CVE-2016-6306.

PolicyCenter S-Series
PC S-Series 1.1 prior to 1.1.3.1 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2180, CVE-2016-2182, CVE-2016-6302, CVE-2016-6304, and CVE-2016-6306.

ProxyAV
ProxyAV 3.5 is vulnerable to CVE-2016-2177, CVE-2016-2182, CVE-2016-6302, CVE-2016-6304, and CVE-2016-6306.

ProxyClient
ProxyClient 3.4 is vulnerable to CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306.

ProxySG
ProxySG 6.5 prior to 6.5.9.13 and 6.6 prior to 6.6.5.2 are vulnerable to CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306.  ProxySG 6.7 is not vulnerable.

Security Analytics
Security Analytics 6.6, 7.1, and 7.2 prior to 7.2.2 are vulnerable to CVE-2016-2177, CVE-2016-2180, CVE-2016-2182, CVE-2016-6304, and CVE-2016-6306.

SSL Visibility
SSLV 3.8.4FC, 3.9 prior to 3.9.7.1, and 3.10 prior to 3.10.2.1 are vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2182, CVE-2016-6304, and CVE-2016-6306.  SSLV 4.0 is not vulnerable.

Unified Agent
UA 4.1, 4.6, and 4.7 are vulnerable to CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306.

X-Series XOS
XOS 9.7, 10.0, and 11.0 are vulnerbale to CVE-2016-2178.

The following products are not vulnerable:
AuthConnector
Blue Coat HSM Agent for the Luna SP
Cloud Data Protection for Salesforce
Cloud Data Protection for Salesforce Analytics
Cloud Data Protection for ServiceNow
Cloud Data Protection for Oracle Sales Cloud
Cloud Data Protection Integration Server
Cloud Data Protection Communication Server
Cloud Data Protection Policy Builder
General Auth Connector Login Application
K9
ProxyAV ConLog and ConLogXP

The following products are under investigation:
IntelligenceCenter
IntelligenceCenter Data Collector
Reporter

Blue Coat no longer provides vulnerability information for the following products:

DLP
Please, contact Digital Guardian technical support regarding vulnerability information for DLP.

Advisory Details: 

This Security Advisory addresses multiple vulnerabilities announced in OpenSSL Security Advisory [22 Sep 2016] and OpenSSL Security Advisory [26 Sep 2016].  Blue Coat products that include a vulnerable version of OpenSSL and make use of the affected functionality are vulnerable.

  • CVE-2016-2177 is an integer overflow flaw in multiple modules that allows a remote attacker to send crafted data and cause heap-based buffer overflow, resulting in application crashes and denial of service.
  • CVE-2016-2178 is a non-constant operation time flaw in the DSA signature implementation that provides a timing side channel. A remote attacker can exploit the side channel to recover private DSA keys through cache-timing attacks.
  • CVE-2016-2179 is a flaw in the X.509 Time Stamp Protocol implementation that allows an attacker to provide a crafted timestamp file to the "openssl ts" application and cause an application crash, resulting in denial of service.
  • CVE-2016-2181 is a flaw in the DTLS server-side replay protection mechanism that allows a remote attacker to force the server to drop legitimate packets as duplicates. This results in denial of service for a specific DTLS connection.
  • CVE-2016-2182 is a buffer overwrite flaw in large number binary conversion that allows a remote attacker to send a certificate or CRL with a large binary number. The attacker can cause memory corruption, resulting in denial of service and possibly arbitrary code execution.
  • CVE-2016-6302 is an integer overflow flaw in TLS session ticket validation that allows a remote attacker to send a crafted session ticket and cause a buffer overread, resulting in an application crash and denial of service.
  • CVE-2016-6303 is an integer overflow flaw in the MDC-2 module that allows a remote attacker to send crafted data and cause a buffer overwrite. This can cause memory corruption, resulting in denial of service and possibly arbitrary code execution.
  • CVE-2016-6304 is a memory leak flaw in the TLS server module that allows a remote attacker to continuously renegotiate a TLS connection with large OCSP TLS extensions. The attacker can cause memory depletion on the TLS server, resulting in denial of service.
  • CVE-2016-6305 is a flaw in SSL/TLS record handling that allows a remote attacker to send an empty SSL/TLS record and cause an endless CPU loop, resulting in denial of service.
  • CVE-2016-6306 is a flaw in the SSL/TLS module that allows a remote attacker to send crafted SSL/TLS messages and cause a buffer overread. This can result in application crashes and denial of service.
  • CVE-2016-6307 is a flaw in SSL/TLS message handling that may allow a remote attacker to send creafted SSL/TLS messages and cause memory depletion, resulting in denial of service.
  • CVE-2016-6308 is a flaw in DTLS message handling that may allow a remote attacker to send creafted DTLS messages and cause memory depletion, resulting in denial of service.
  • CVE-2016-6309 is a flaw in SSL/TLS message handling introduced by the fix for CVE-2016-6307. It allows a remote attacker to send crafted SSL/TLS messages and cause memory corruption, resulting in denial of service and possibly arbitrary code execution.
  • CVE-2016-7052 is a flaw in CRL processing that allows a remote attacker to cause an application crash through the usage of CRLs, resulting in denial of service.

Blue Coat products may act as both client and server in SSL/TLS connections, and may use application functionality for cryptographic operations.  Blue Coat products act as a client when connecting to Blue Coat services such as WebPulse, DRTR, and licensing and subscription services.  Products should be considered vulnerable in all interfaces that provide SSL/TLS connections for data and management interfaces unless the CVE is specific to SSL/TLS client or server functionality (as noted in the descriptions above) or unless otherwise stated below:

  • CacheFlow: All CVEs affect only management connections.
  • MC: CVE-2016-2178 only affects PDM connections from ProxySG.

Blue Coat products that use a native installation of OpenSSL but do not install or maintain that implementation are not vulnerable to any of these CVEs.  However, the underlying platform or application that installs and maintains OpenSSL may be vulnerable.  Blue Coat urges our customers to update the versions of OpenSSL that are natively installed for Client Connector for OS X, Proxy Client for OS X, and Reporter 9.x for Linux.

Some Blue Coat products do not enable or use all functionality within OpenSSL.  The products listed below do not utilize the functionality described in the CVEs below and are thus not known to be vulnerable to them.  However, fixes for these CVEs will be included in the patches that are provided.

  • ASG: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • Android Mobile Agent: CVE-2016-2177, CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, CVE-2016-6304, and CVE-2016-6306
  • CacheFlow: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • Client Connector: CVE-2016-2178, CVE-2016-2179, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • CAS: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, and CVE-2016-6303
  • Director: CVE-2016-2179
  • MTD: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, and CVE-2016-6303
  • MAA: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, and CVE-2016-6302
  • MC: CVE-2016-2179, CVE-2016-2181, CVE-2016-6302, and CVE-2016-6304
  • ICSP: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • NNP: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • NSP: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • PS: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-2182, and CVE-2016-6302
  • PS S-Series: CVE-2016-2179 and CVE-2016-2181
  • PC: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-2182, and CVE-2016-6302
  • PC S-Series: CVE-2016-2179 and CVE-2016-2181
  • ProxyAV: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, and CVE-2016-6303
  • ProxyClient: CVE-2016-2178, CVE-2016-2179, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • ProxySG: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • Security Analytics: CVE-2016-2178, CVE-2016-2179, CVE-2016-2181, and CVE-2016-6302
  • SSLV: CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, and CVE-2016-6303
  • UA: CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-6302, CVE-2016-6303, and CVE-2016-6304
  • XOS: CVE-2016-2177, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-2182, CVE-2016-6302, CVE-2016-6304, and CVE-2016-6306
Workarounds: 

These vulnerabilities can be exploited in CacheFlow only through the management interface.  Allowing only machines, IP addresses and subnets from a trusted network to access the CacheFlow management interface reduces the threat of exploiting the vulnerabilities.

Patches: 

Advanced Secure Gateway
ASG 6.6 - a fix for CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306 is available in 6.6.5.2.  A fix for the remaining CVEs is not available at this time.

Android Mobile Agent
Android Mobile Agent 1.3 - a fix is available in 1.3.8.

BCAAA
BCAAA 6.1 - a fix will not be provided.  An updated Novell SSO SDK is no longer available.  Please, contact Novell for more information.

CacheFlow
CacheFlow 3.4 - a fix is not available at this time.

Client Connector
Client Connector 1.6 - a fix will not be provided.  Please upgrade to the latest version of Unified Agent with the vulnerability fixes.

Content Analysis System
CAS 1.3 - a fix is not available at this time.

Director
Director 6.1 - a fix is not available at this time.

Mail Threat Defense
MTD 1.1 - a fix is not available at this time.

Malware Analysis Appliance
MAA 4.2 - a fix is available in 4.2.11.

Management Center
MC 1.7 - a fix is not available at this time.

Norman Shark Industrial Control System Protection
ICSP 5.3 - a fix is not available at this time.

Norman Shark Network Protection
NNP 5.3 - a fix is not available at this time.

Norman Shark SCADA Protection
NSP 5.3 - a fix is not available at this time.

PacketShaper
PS 9.2 - a fix is not available at this time.

PacketShaper S-Series
PS S-Series 11.7 - a fix is available in 11.7.1.1.
PS S-Series 11.6 - a fix is available in 11.6.2.2.
PS S-Series 11.5 - a fix is not available at this time.
PS S-Series 11.4 - a fix will not be provided. Please upgrade to a later version with the vulnerability fixes.
PS S-Series 11.3 - a fix will not be provided. Please upgrade to a later version with the vulnerability fixes.
PS S-Series 11.2 - a fix will not be provided. Please upgrade to a later version with the vulnerability fixes.

PolicyCenter
PC 9.2 - a fix is not available at this time.

PolicyCenter S-Series
PC S-Series 1.1 - a fix is available in 1.1.3.1.

ProxyAV
ProxyAV 3.5 - a fix is not available at this time.

ProxyClient
ProxyClient 3.4 - a fix will not be provided.  Please upgrade to the latest version of Unified Agent with the vulnerability fixes.

ProxySG
ProxySG 6.7 - a fix for all CVEs is available in 6.7.1.1.
ProxySG 6.6 - a fix for CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306 is available in 6.6.5.2.  A fix for the other CVEs is not available at this time.
ProxySG 6.5 - a fix for CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306 is available in 6.5.9.13.  A fix for the other CVEs is not available at this time.

Security Analytics
Security Analytics 7.2 - a fix is available in 7.2.2.
Security Analytics 7.1 - a fix is available through a patch RPM from Blue Coat Support.
Security Analytics 6.6 - a fix is available through a patch RPM from Blue Coat Support.

SSL Visibility
SSLV 3.11 - a fix is available in 3.11.1.1.
SSLV 3.10 - a fix is available in 3.10.2.1.
SSLV 3.9 - a fix is available in 3.9.7.1.
SSLV 3.8.4FC - a fix is not available at this time.

Unified Agent
UA 4.7 - a fix is not available at this time.
UA 4.6 - a fix will not be provided. Please upgrade to the latest version with the vulnerability fixes.
UA 4.1 - a fix will not be provided. Please upgrade to the latest version with the vulnerability fixes.

X-Series XOS
XOS 11.0 - a fix is not available at this time.
XOS 10.0 - a fix is not available at this time.
XOS 9.7 - a fix is not available at this time.

Advisory History: 

2017-03-16 A fix for SSLV 3.10 is available in 3.10.2.1.
2017-03-08 MC 1.8 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2180, CVE-2016-2182, and CVE-2016-6306.  ProxySG 6.7 is not vulnerable.  SSLV 4.0 is not vulnerable.  A fix for PolicyCenter S-Series is available in 1.1.3.1.
2017-02-07 A fix for Android Mobile Agent is available in 1.3.8.  Vulnerability inquiries for DLP should be addressed to Digital Guardian technical support.
2017-01-27 A fix for Security Analytics 7.2 is available in 7.2.2.
2017-01-13 A fix for SSLV 3.9 is available in 3.9.7.1.
2016-12-19 A fix for MAA is available in 4.2.11.
2016-12-02 A fix is available in SSLV 3.11.1.1.
2016-11-29 A fix for PacketShaper S-Series 11.6 is available in 11.6.2.2.  PacketShaper S-Series 11.7 is not vulnerable because the fix is available in 11.7.1.1.
2016-11-11 SSLV 3.10 is vulnerable to CVE-2016-2177, CVE-2016-2178, CVE-2016-2182, CVE-2016-6304, and CVE-2016-6306.  A fix is not available at this time.
2016-11-09 A fix for CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306 is available in 6.5.9.13.
2016-11-08 Fixes for Security Analytics 6.6 and 7.1 are available through RPM patches from Blue Coat Support.
2016-10-24 A fix for CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306 in ProxySG 6.6 is available in 6.6.5.2.  A fix for CVE-2016-2177, CVE-2016-2182, and CVE-2016-6306 in ASG is available in 6.6.5.2.  Fixes for the remaining CVEs is not available at this time.
2016-10-06 initial public release

Feedback